Support Matrix

The tables below detail the configurations and versions supported for the First-gen Gaudi and Gaudi®2 platforms:

SynapseAI

1.7.1

Gaudi Firmware

1.2.2

Gaudi SPI Firmware

1.1.0

Operating Systems

Ubuntu

Ubuntu

Amazon Linux 2

RHEL8

Version

20.04

18.04

8.6

Kernel

5.4.0 and above

4.15 and above

5.4.0 and above

4.18.0

Python

3.8

Kubernetes

1.23, 1.22, 1.21

OpenShift

4.11

Docker

18.09.0

PyTorch

1.13.0

PyTorch Lightning

1.7.7

DeepSpeed

Forked from v0.7.0 of the official DeepSpeed. Refer to DeepSpeed Validated Configurations.

TensorFlow

2.8.4 and 2.10.1

Habana Horovod

Forked from v0.25.0 of the official Horovod

Open MPI

4.1.2

Libfabric

1.16.1

SynapseAI

1.7.1

Gaudi2 Firmware

1.7.1-fw-38.3.0

Gaudi2 SPI Firmware

1.7.1-fw-38.3.0

Operating Systems

Ubuntu

Version

20.04

Kernel

5.4.0 and above

Python

3.8

Docker

18.09.0

PyTorch

1.13.0

TensorFlow

2.8.4 and 2.10.1

Habana Horovod

Forked from v0.25.0 of the official Horovod